Paso a Paso!

Como todos sabemos los algoritmos son un conjunto de pasos para resolver problemas de forma organizada y clara; estos pasos deben ser precisos, definidos y finitos.

Ahora bien mi idea no es escribir un libro de algoritmia, es solo servir de apoyo a quienes se les hace un poco difícil comprender como funcionan los condicionales y los ciclos repetitivos (por ahora), si buscas que te expliquen con una gran dosis de tecnicismo aquí no es la cosa, la idea es que alguien que en su vida haya oído del tema pueda entender y utilizar los ciclos repetitivos. Por cierto no voy a usar una sintaxis en particular pero daré ejemplos en PASCAL y PYTHON.

CONDICIONAL SI (IF)

Lo utilizamos cuando queremos que una acción ocurra dependiendo de que si se cumple, con una condición.

{la forma mas simple}
Si  <condición> Entonces
  aquí colocamos que va a hacer el programa si la <condición> se cumple
Finsi

También podemos hacer que ocurra un evento si la condición no se cumple.

Si  <condición> Entonces
   aquí colocamos que va a hacer el programa si la <condición> se cumple
Sino
   aquí colocamos que va a hacer el programa si la <condición> no se cumple 
Finsi

Es posible que evaluemos varias condiciones. veamos unos ejemplos.

Realice un algoritmo que evalúe cual es el mayor de dos números.

ALGORITMO numero_mayor

Declarar
  Variables
   a:entero
   b:entero
INICIO
  escribir "algoritmo para determinar el numero mayor"
  escribir "ingrese el primer numero: A"
  leer(a)
  escribir "ingrese el segundo numero: B"
  leer (b)
  Si (a>b)entonces
     escribir "A es el mayor"
  Sino
     Si (b>a) entonces
     escribir "B es el mayor"
     Sino
     escribir "son iguales"
     finsi 
  finsi
FIN
EN PASCAL EL MISMO PROGRAMA  SE IMPLEMENTARÍA ASÍ:
program numero_mayor (input,output);

uses crt;
var 
a, b:integer;
BEGIN
    writeln ('Programa para Determinar el Numero Mayor');
    writeln ('Ingrese el primer numero A:');
    readln (a);
    writeln ('Ingrese el segundo numero B:');
    readln (b);
    if (a > b) then 
       begin
         writeln ('A es el mayor');
       end
    else
        begin
           if (b > a) then
             begin
              writeln ('B es el mayor');
             end
           else
              writeln ('son iguales');  
        end;
END.
Por los momentos no ahondare en la sintaxis de PASCAL.
CASO (CASE)
Caso <variable> 
  1:sentencias
  2:sentencias
  3:sentencias
fin caso
{las variables utilizadas pueden ser de tipo numérico o carácter}
caso <variable> 
  a:sentencias
  b:sentencias
  c:sentencias
fin caso


veamos un ejemplo
.
.
escribir "que operación desea realizar"
escribir "1). Suma, 2). Resta, 3). Salir"
leer (opt)
caso opt 
1: c=a+b
   escribir "la suma de A+B es C:", C;
2: c=a-b
   escribir "la resta de A-B es C:", C;
3: salir;
fin caso
.
.
.

 

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s